IMPORTANT: NPAPI Plugins no longer work on Chrome

Google announced last year that they will no longer support NPAPI plugins on Chrome starting September 1, 2015.  You may wonder, “How does this affect me?” Well, lets see what is considered a NPAPI plugin – Silverlight, Java, Citrix Receiver, and more.  Any websites that required a NPAPI plugin will no longer work in Chrome.  As a workaround, you would have to use a different browser such as Firefox, IE, or Safari.

UMD’s Panopto server used to require Silverlight in order to view the videos.  But thanks to the summer upgrades, Silverlight is no longer needed since the upgraded version Panopto uses HTML5.

People that were using Chrome to access SmithApps will notice that none of the application will launch.  As a workaround, please use a different browser such as Firefox, IE, or Safari.  Another option is to login via Citrix Receiver (see instructions at http://it.rhsmith.umd.edu/smithapps#access_citrix.)

To learn more about this, please visit the links below.

Google Support: https://support.google.com/chrome/answer/6213033?hl=en

Chromium Blog: http://blog.chromium.org/2014/11/the-final-countdown-for-npapi.html

So if you stumble upon a website that doesn’t work, try a different browser as it may need a NPAPI plugin.

You may also like...

Leave a Reply