Panopto update – new browsers required

Update your browsers and your flash if you have any trouble viewing or creating video with Panopto.  The newest version uses HTML5 for playback.

All UMD Panopto users are reminded that they have to update their browsers to the latest version and download Flash Player if they’ve not already done so.

If you have any questions or concerns please contact itsc@umd.edu.

 

You may also like...

Leave a Reply